Dragon's Lair Fans - Arcade Lifestyle
February 23, 2020, 01:49:19 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: ALS'/DLF' : your daily dose of Arcade Life Style...inside the Dragon's Lair!
 
  Home Help Search Calendar Gallery Login Register  
  Show Posts
Pages: [1] 2 3 ... 7
1  General Chat / Technical Area / Re: Data East Hybrid RCDM_I107 on: October 25, 2018, 08:06:02 PM
Nice work Smiley

You have a good website too, lots of good info and repair ;logs on there, I like your IC list PDF. Seems like a good quick reference for lots of devices.
2  General Chat / Arcade Lifestyle / Re: Sega Hockey TV - Another Pong-Clone on: September 12, 2017, 09:59:59 PM
Very Nice, great save.  Smiley
3  General Chat / Technical Area / Re: Atari Pole Position. Where's the road gone? FIX LOG. on: June 16, 2017, 09:28:15 PM
...I was wondering if u ever found out what wrong with the pole position with mountain and cloud problem

Hi, I'm pretty sure it was a bad socket on the Prom at 4L on the Video PCB that fixed this issue, I didn't write this one up, but I'd take a look at that part of the schematic and see if you can find anything.
4  General Chat / Arcade Lifestyle / Re: Another Swedish Roadtrip on: June 05, 2017, 08:48:44 PM
When you guys open your arcade i'll be coming over for a visit!  lol

You guys have picked some great cabs in your last raids, well done.
5  General Chat / Arcade Lifestyle / Re: Another Swedish Roadtrip on: June 04, 2017, 07:10:38 PM
Very cool find guys, congrats.  Smiley
6  General Chat / Technical Area / Re: Sprint 1 troubleshooting on: March 02, 2017, 09:47:52 PM
Quick question, when in test mode do you hear a screech sound every time you change gear 1,2,&3? Changing to 4th gear shouldn't make any sound in test mode.

7  General Chat / Technical Area / Re: Taito Space Invaders PtII 3-Layer Repair Log on: February 26, 2017, 03:00:19 PM
Nice fix and well documented Smiley
8  General Chat / Technical Area / Re: Atari Breakout PCB repair. Work In Progress on: February 15, 2017, 08:19:32 PM
I will make a diagram over the weekend of exactly how I have this connected up.

The repair is slightly on hold at the moment as I have a few other projects which take priority.
9  General Chat / Arcade Lifestyle / Re: The planning and built of My Gameroom on: February 06, 2017, 09:13:58 PM
Looks like a great space you've made, plenty of room for tinkering with all sorts!
10  General Chat / Arcade Lifestyle / Re: Warehouse Pickup with Pinge, Kralleman & Rogerxy 23/10-2016 on: January 28, 2017, 06:29:36 PM
Looking forward to seeing all your goodies.  Smiley
11  General Chat / Arcade Lifestyle / Re: Roadtrip 6/1-2017 Atari Dominos Pickup for Kralleman on: January 24, 2017, 07:25:09 PM
 Shame the IC didn't fix the problem, I will try and digest what you've written in the next few day and think of some other areas you can't test. I'll take a look at the Ops manual as they are pretty descriptive in he theory of operation for these early boards.

Can you confirm that the pin that is stuck high isn't shorted to the 5v rail probably on a trace on the underside of the PCB or any other signal nearby.

Give the ROM legs a clean too with a light rub from some sandpaper or similar if you haven't already.
12  General Chat / Technical Area / Re: Burning roms (2716) on: January 20, 2017, 02:23:15 PM
The MiniPro which you have will read 2716 Eproms but cannot program the majority of them due to the requirement for 24-25 Volt DC to write to them.

You can use a 28c16 Flash device as a direct replacement for a 2716 and the minipro programs them fine.

The MiniPro is a very good apart from 2716 programming, its built in logic and ram test are very useful.
13  General Chat / Arcade Lifestyle / Re: Roadtrip 6/1-2017 Atari Dominos Pickup for Kralleman on: January 12, 2017, 07:09:35 PM
@Pinge, thanks for those CP images, It gives me an idea of what one should look like. They are great for now, at some point I may like a close up of the Domino logo in the middle so I can reproduce it.

@Kralleman, You're making progress well done Smiley So the 7432 at P3 is an or gate, if either input is high you will get a high output, because pin 10 is always high the output will be held high. Like you say tracing that back to the 9301 at D2 show all of those input signals on pins 1,2,14, & 15 are pulsing it is highly likely D2 is faulty. You'd really need a logic analyser to confirm the timing of the input signals which should trigger the output on pin 7, be in reality I'd say swap D3 out and forget about needing any higher tech knowledge.

These 9301's are not available anywhere anymore I'd be interested to see what data sheet you found and what that seller was actually selling?

Take a look at my Super Breakout repair thread I just posted in the tech forum. I've had a batch of boards made up to replace the 9301 with a 7442 which is essentially the same device with a different pinout and is readily available, PM me your address and I'll send you a few of them Smiley
14  General Chat / Technical Area / Another Super Breakout PCB repair (Bonanza Enterprises Clone) on: January 12, 2017, 06:55:54 PM
Here's another fix I hope you enjoy reading... I've posted this elsewhere on the web I'm sure some of you will have seen it already, but for everyone else  Ghost Ghost Ghost

So part of my Cocktail restoration was to fix the Super Breakout game board that came with it. I knew it was faulty after my initial taesting of the cab a few months back.

The board itself has now manufacturing marking or anything to say who made it. From studying photos of Atari boards this appears to be a direct 1:1 copy of a Rev-03 board. The only difference I noted was changing of the audio amplifier which would be a TD1004, this PCB has an LM380 on a small daughter board that plugs into the TDA1004 socket location. Image below showing the PCB in its original faulty state. 



When plugged in with a basic adaptor providing 5V DC for the game logic and video output to my monitor. The game was displaying garbage on the screen that was almost static but some characters did move and change here and there. The game looked the same in test mode as well.



So checking the reset line on the CPU (pin 40) it was constantly changing state when it should have been held high after the initial board power up, this means the game code is not running correctly for some reason and the CPU is being restarted to try and get the game code from the ROM's running and initialised correctly.

After a few more quick checks of the clock signals and confirming the address & data bus were active, I took a look at the signals on the main ROMs the run the game program and found 3/4 of the ROM select lines we not active. From memory one had no signal and the other two were stuck high. THE IC location was F2 and is a 3901 chip which is obsolete and unobtainable, With the help of someone on the DLF forums and PhilMurry I had some converter PCB's made up which worked with a 7442 IC.

I had previously made a very rough adaptor show below,



These new adaptor boards are a vast improvement!



Changing this IC got the ROM select lines active but the game was still resetting and the screen was full of garbage still.  Checking around the reset circuit I found another 3901 IC that I suspected was faulty. This one at location E8 should have been triggering a Timer Reset signal which if working correctly would clear a timing circuit that stops the CPU from being reset assuming everything else was working OK.

Next up I decided to check the RAM with my logic probe, visibly using the probe all the signals were active, but I had little other way to confirm if they were working as the game was not running. I decided to remove all eight RAM's and socket them. I then fitted some new 2102 ram, using this method once the game was running I could put back the original RAM and confirm which one did or didn't work.



So with all eight RAM's changed we had what look like part of the Playfield being drawn but not a lot else. The CPU was still resetting so the code still wasn't running correctly.



Flicking the game into test mode the display was now stable and showing a ROM error, a good sign. This ROM was at PCB location L1. I removed it and cleaned the chip legs and fitted it back in the socket.



Boom! the game was running, but the balls we just faint 'dots' on the screen and not moving correctly. More diagnosing found another two 3901 IC's that were faulty, each of these IC's should have been sending ROM and position data to the Motion generator circuit where the balls and their movement is calculated. These two IC's were at locations K8 and P7, the upside of fixing this fault was that it also fixed an audio fault i hadn't yet discovered! The IC at P7 and output signal (*TONES) on pin 11 was stuck high. This is an enable line for the audio latch that combines data signals and turns them into the game sound. I check with an audio probe and found I had a constant garbage sound playing when in game and test mode.

So with those two IC's replaced the game looked to be playing, test mode showed no problems, but the balls were being doubled up, each of the three balls was being generated twice, they were tracking each other and moving in an identical pattern, they just shouldn't have been there. I thought this would be an easy fix...



Fast forward Seven or so hours of faultfinding I found the problem. Now this was something a Logic probe and an Oscilloscope couldn't help find.

Eventually the only IC's I was left with that could have something to do with the problem were a pair of 7483's they are used as comparators to compare a RAM value with the vertical line that is being displayed, if they match three load pulses are triggered which are used by the video shift registers.

I didn't have replacements for these but decided to remove them and fit sockets. I intentionally put them back in different positions, and the fault appeared to be gone. Fitting them back into their original positions the fault came back. Looking at the schematics we can conclude that the IC at M4 had a faulty input on pin 13. I will temporarily use them but have ordered some new replacements.



A final look at the board wired to my test rig. The total IC's replaced is as follows:

F2 - 3901 - ROM Selects
F,H,J,K4  - Ram 2102
F,H,J,5     - Ram 2102
E8 - 3901 - Reset circuit
K8 - 3901 - Ball motion circuit
P7  - 3901 - Ball motion circuit & Sound
M4 - 7483 - Ball motion circuit



The game has been play tested in the cabinet and all controls, sound, Input and Output all work correctly.

If you made it this far well done!

Thanks for reading, Mart. Smiley

15  General Chat / Arcade Lifestyle / Re: Roadtrip 6/1-2017 Atari Dominos Pickup for Kralleman on: January 08, 2017, 08:23:38 PM
I had some time yesterday to look more into the pcb troubles. When plugged in, the screen shows garbage letters and digits. The watchdog is barking at the 6502 as often as it can so the CPU is being constantly reset. There seems to be activity on all address and data lines, both on CPU side of things and on RAM/ROM side. I can't see any stuck pins on ram/roms. One is floating on one of the rams but it's not supposed to be connected to anything. I tried replacing the cpu but it did not help. I only used my logic probe yesterday but I guess I need to start scoping things out. I might also try to disable the watchdog just to see what happens. There's no watchdog disable signal on the schematics but I guess I could just tie the output to gnd (it's then inverted before reaching the cpu), or?

The roms seem to be mask roms. I don't have the board nearby atm and don't quite remember the model. Anyway, I bet my shitty eprom programmer won't be able to read them.

Rams are 2102a. I don't have any spares or otherwise I wouldve tried piggybacking.

The problem with the reset is present both when test mode is on and off so I guess it's related to something early on in the boot process. I'm not sure what roms are responsible for what.

I just had a look at he schematics and theyíre very similar to other Atari games of this era. Take at look at the 3901ís at F2,D2 and E8, Iíve seen those all have a high failure rate, outputs usually stuck high or showing no signal, they control the Prom select lines & part of the reset circuit amongst others. These 3901ís all being faulty will contribute to the CPU watchdogging.

Also going from my previous repairs, if the RAMís are made by NEC iíd also say thereís a high chance they will be faulty.

Reading the MAME source file Roms at D1 & E1 contain the CPU program.

EDIT, if you have the prom version of the board they are locations at L1,L0,M1,M0,N1,N0,P1,P0. This is very similar to a Super Breakout board in PCB layout and design.

Good luck with the repair.
Pages: [1] 2 3 ... 7
Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!